Community Forum Share your projects and post your questions

Register or Sign In

NuGet Library "ABElectronics_Win10IOT_Libraries" error

72 Views - Created 30 days ago

30 days ago

Posted by:
washburn_it

Users Avatar

Hi,

I'm going to buy the ADC Pi and I would like to use it with a Raspberry with Windows 10 IOT.
I'm using Visual Studio 2015 Community to develop the software but when I go to install the library in the subject I get the error that the NuGet package is not compatible.
Is it not compatible?

Thank you, regards.

 

Roberto
 


 

 

 

30 days ago

Posted by:
andrew

Users Avatar

Location:
United Kingdom

Users Twitter  Users Website  

Hello Roberto

Our Windows 10 IOT library was developed on Visual Studio 2017 Community so you may need 2017 for the NuGet package to install.

AB Electronics UK Tech Support

30 days ago

Posted by:
washburn_it

Last edited: 19/04/2019

Users Avatar

Sorry, I was wrong...I have Visual Studio 2017 Community...just in case it was an issue on my installation, is it possible to "interact" with the ADC Pi without your library?

 

Roberto

29 days ago

Posted by:
andrew

Users Avatar

Location:
United Kingdom

Users Twitter  Users Website  

Hello Roberto

It appears that Microsoft had updated the way Windows 10 IOT works in the latest version which broke the NuGet package for our libraries.  I have updated the NuGet package and it should now install with the package manager using the following command:

Install-Package ABElectronics_Win10IOT_Libraries -Version 1.2.7048.20748

If you still have trouble installing the package you can download the package from our GitHub repository at https://github.com/abelectronicsuk/ABElectronics_Win10IOT_Libraries

Copy the ABElectronics_Win10IOT_Libraries/bin/Release/ABElectronics_Win10IOT_Libraries.dll file into your project directory and add a reference to it in the References folder.

You should then be able to reference the library by adding the line below to the top of your code.

using ABElectronics_Win10IOT_Libraries;

 

AB Electronics UK Tech Support

25 days ago

Posted by:
washburn_it

Users Avatar

It worked, thanks !
Regards,

 

Roberto

 

 

Note: documents in Portable Document Format (PDF) require Adobe Acrobat Reader 5.0 or higher to view, download Adobe Acrobat Reader or other PDF reading software for your computer or mobile device.