About Us Knowledge Base Community Forum Electronics Toolbox FAQ Shipping & Delivery

Community Forum

Share your projects and post your questions

Search
Register or Sign In
Forum

Serial Pi Plus not working

232 Views - Created 02/01/2019

02/01/2019

Posted by:
confused

Users Avatar

I am having difficulties getting the Serial Pi Plus working, allthough using the given instructions. I have the Raspberry Pi 3 B+. Serial Pi Plus is the only connected hardware.

I am running Rasbian with latest Updates and Upgrades.

Below is my setup.

/boot/cmdline.txt:

dwc_otg.lpm_enable=0 console=tty1 root=/dev/mmcblk0p7 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait splash plymouth.ignore-serial-consoles quiet

End of /boot/config.txt:

enable_uart=1

dtoverlay=pi3-miniuart-bt

 

 

In Raspberry configuration I have enabled the following interfaces:

SSH

Serial Port

Remote GPIO

 

The Serial Console is disabled

 

When doing the loopback test, connecting pins 2 & 3 in the DB9 and using either Putty or minicom with baud rate 9600 thru /dev/ttyS0, keystrokes are not echoed, nothing appears. I am doing this under sudo, so permissions shouldn’t be an issue. When connected to external device thru rs232 I can receive data but not able to send anything.

 

Are my settings correct?

Is there a way to debug the hardware to detect possible malfunction of the Serial Pi Plus?

 

Any advice on how to make the setup working?

02/01/2019

Posted by:
andrew

Users Avatar

Location:
United Kingdom

Users Twitter  Users Website  

Hi

Try commenting out the "enable_uart=1" line in the /boot/config.txt and use /dev/ttyAMA0 instead of ttyS0.

When you add the "dtoverlay=pi3-miniuart-bt" line to the /boot/config.txt it redirects the ttyAMA0 hardware uart port from the bluetooth device to the UART pins on the GPIO header.

You may also need to disable hardware flow control in minicom for it to work correctly.

AB Electronics UK Tech Support

02/01/2019

Posted by:
confused

Users Avatar

Hi Andrew,

 

thanks for the quick reply.

However, it didn't help. No change in the behaviour.

Any other tricks to try?

02/01/2019

Posted by:
andrew

Users Avatar

Location:
United Kingdom

Users Twitter  Users Website  

Try connecting the two UART pins together, pin 8 (GPIO 14) and pin 10 (GPIO 15) on the GPIO port without the serial pi plus connected.  If the UART port is working then the keystrokes in minicom should be echoed, if not then that would suggest either a software or hardware problem with the Raspberry Pi.

If the UART port does echo the keystrokes then it could be a fault with the Serial Pi Plus and I will send you a replacement.

AB Electronics UK Tech Support

03/01/2019

Posted by:
confused

Users Avatar

Hi Andrew,

the second loopback test failed as well.

So I took a fresh Pi from the shelf and started all from scratch. Now the loopback with Serial Pi Plus works, with the above proposed configurations.

Great!

Thanks a lot for the support. 

Note: documents in Portable Document Format (PDF) require Adobe Acrobat Reader 5.0 or higher to view, download Adobe Acrobat Reader or other PDF reading software for your computer or mobile device.