Community Forum

Share your projects and post your questions

1 Wire Pi and 1 Wire Pi Plus

w1_master_driver w1_bus_master1: Family 0 for 00.700000000000.f8 is not registered.

2215 Views - Created 29/01/2017

29/01/2017

Posted by:
Lomax

Users Avatar

Location:
At sea

I have followed the setup instructions in the knowledge base, and can query my sensors from Python, but I'm seeing messages like this in my syslog about once per minute:

w1_master_driver w1_bus_master1: Family 0 for 00.680000000000.a7 is not registered.

What might be causing this?

29/01/2017

Posted by:
andrew

Users Avatar

Location:
United Kingdom

Users Facebook  Users Twitter  Users Website  

Hi

It seems to be a problem with the w1-gpio dtoverlay which I think is used to connect to 1 wire devices through a gpio pin.  If you disable this by commenting out the line dtoverlay=w1-gpio in /boot/config.txt and reboot it should stop showing the error in the syslog.

AB Electronics UK Tech Support

29/01/2017

Posted by:
Lomax

Users Avatar

Location:
At sea

Thanks Andrew, that did indeed get rid of those warnings! Can't remember when or why I enabled this overlay - maybe it was raspi-config that did it, when I used it to enable the 1-Wire interface.

30/01/2017

Posted by:
Lomax

Users Avatar

Location:
At sea

A further observation: after removing the w1-gpio overlay, CPU usage has dropped considerably - load average has gone from 0.15-0.20 to 0.00-0.04. This is with Domoticz running and reading a few 1-Wire sensors, all the 1-Wire services, sshd and iptables and the usual system daemons. Remarkable!

Note: documents in Portable Document Format (PDF) require Adobe Acrobat Reader 5.0 or higher to view, download Adobe Acrobat Reader or other PDF reading software for your computer or mobile device.